Auphonic Error

Something has happened to the Auphonic module. When i choose a file and press “Create production” nothing happens. No error message or anything. When i look in the javascript console i get this error message.

XMLHttpRequest cannot load https://auphonic.com/api/productions.json. No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://thedomain.se’ is therefore not allowed access. The response had HTTP status code 400.

I have tried adding/removing the module but still not working. I have a multisite with multiple podcasts if that matters at all. Any ideas?

After some pulling of my non existing hair i got it working. But it would be nice with some validation of the fields so you know what you’ve done wrong. I think i had to many characters in the “Subtitle” or “Summary” cause i shortened the content in those fields and then it worked!

So mark as feature request or something? :stuck_out_tongue:

I have a similar one since a few months.
“Subtitle” and “Summary” fields are empty.

After selcting the file I want to send to Auphonic from the computer and hitting the “Create Production” button the “Please select file” banner changes to “creating production” and that’s it. Nothing more happens.
The console gives me:

Uncaught TypeError: Cannot read property ‘split’ of undefined
at extract_auphonic_data_from_form (admin.js?ver=2.8.6:254)
at Object.success (admin.js?ver=2.8.6:353)
at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:2)
at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:2)
at y (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4)
at XMLHttpRequest.c (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4)
extract_auphonic_data_from_form @ admin.js?ver=2.8.6:254
success @ admin.js?ver=2.8.6:353
i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:2
fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:2
y @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4
c @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4
XMLHttpRequest.send (async)
send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4
ajax @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:4
create_auphonic_production @ admin.js?ver=2.8.6:348
(anonymous) @ admin.js?ver=2.8.6:600
dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:3
r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.2:3

I already disconnected and reconnected to Auphonic, used the Tools to clear cache and repair.
Same bug is described here on Github: https://github.com/podlove/podlove-publisher/issues/1045

Current workaround is to get everything done on the Auphonic site and then in WordPress
“Select existing production” > “Get production results” > “Import Episode Metadata”
Does anyone have the same problems? Any ideas how to fix it?
Thanks a lot!

Versions and plugins used:
PHP Version 7.2.18-he.0
WordPress Version 5.2
WordPress Theme Make v1.9.15
Active Plugins
- Akismet Anti-Spam v4.1.2
- Archivist - Custom Archive Templates v1.7.4
- Contact Form by ContactMe.com v2.3
- Google Analytics v2.1.5
- Invitations for Slack v1.0.2
- Jetpack by WordPress.com v7.3.1
- WP Options Importer v5
- Podlove Podcast Publisher v2.8.6
- Podlove Web Player v2.1.0
- Public Post Preview v2.8.0
- Query Shortcode v0.2.1
- WordPress Importer v0.6.4
- WP Tiles v1.1.2
WordPress Database Charset utf8
WordPress Database Collate
Publisher Version 2.8.6
Web Player Version player_v2
Twig Version 1.38.3
open_basedir ok
curl Version 7.38.0
iconv available
simplexml ok
max_execution_time 30
upload_max_filesize 32M
memory_limit 256M
disable_classes
disable_functions syslog
permalinks ok (/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on

ich bekomm den Fehler aktuell auch, gibt es einen fix dafür?

admin.js?ver=2.9.1:254 Uncaught TypeError: Cannot read property ‘split’ of undefined
at extract_auphonic_data_from_form (admin.js?ver=2.9.1:254)
at Object.success (admin.js?ver=2.9.1:353)
at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=5.2.2:2)
at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=5.2.2:2)
at x (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=5.2.2:4)
at XMLHttpRequest.c (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=5.2.2:4)

Ich würde mich über irgendeine Reaktion freuen. Auch wenn es ist, wir können da nix machen.

Kannst du mal einen report posten, welche plugins, PHP version usw du nutzt? Funktioniert bei dir der Workaround über Auphonic direkt und dann ins WordPress übernehmen?

Ich habe mir das Classic Editor Plugin geholt und aktiviert. Damit geht dann auch wieder der Upload direkt aus dem WordPress zu Auphonic. Allerdings gibt es dann einige Problem mit den Chapters.