Feed page completely blank - both mp3 and main


#1

Hi all,

I hope someone can help me. I am new to wordpress and am trying out Podlove to get podcasting.

Unfortunately when I have podlove activated my feed page is completely blank. It is: https://gatm.sims-jenkins.com/feed/

Directing my browser (Chrome) to the mp3 feed https://gatm.sims-jenkins.com/feed/mp3/ causes the browser to download a blank file named ‘download’

When I deactivate Podlove my feed comes back. I only have two other plugins installed - LSCache and Really Simple SSL.

I found a functions.php file in wp_includes and removed a blank line at the end of the file, but that did nothing. I am using the Twenty Fifteen theme.

I hope someone can help me!

Thanks,
Charity


#2

Have you tried this with the caching plugin turned off?


#3

Thanks for your quick response.

Yes, I first tried deleting both the other plugins leaving Podlove the only plugin and then I still had the issue.

Then I deactivated Podlove and reinstalled the other plugins, and the issue went away.

When I reactivated Podlove and refreshed the feed, it appeared the first time (a longer feed than before), but then when I refreshed the page it went blank and has stayed blank ever since.

I just re-tried to make sure - I purged the cashe, deactivated the caching plugin and then refreshed my feed. Still not working.


#4

I just could not figure it out, and as it was a new site in which I’d tried and removed a few different things, I decided to uninstall and reinstall wordpress. The feed seems to be working now! If the issue returns I’ll be back I guess… Thanks for your help!


#5

OK I’m back! When I installed Litespeed plugin again the feeds stopped working again. However, I cannot fix this by uninstalling Litespeed cache. When I uninstall the plugin, the feeds are still not working–same issue as before. Could it be something about the interaction between the two plugins?


#6

Next update. I tried accessing the feed from my phone browser and it worked, so I realised I needed to clear the browser cache on my computer. Now the feed is working again!

However, the problem remains that it was not working with the combination of Podlove and Litespeedcache. Is there a known issue with using caching plugins alongside Podlove. Do I not need a caching plugin because there is caching done by Podlove?

Thanks in advance for your advice!


#7

Podlove does some caching but no complete “page cache”. Caching plugins are quite intrusive and might cause issues. I have never used “Litespeedcache” before so I cannot say if there are issues. I have seen “Comet Cache” used successfully in combination with Podlove Publisher.