Http -> https redirect error


#1

Hi there,
my hosting provider recently enforces https¹ which causes a redirect loop.

I want to change the feed URL from
http://mais1cafe.org/feed/standard/
to
https://mais1cafe.org/feed/standard/

I can t find a way how to change this though. Neither in the Podlove-Dashboard nor in MySQL-Admin. Strange behaviour happens when I add a new feed. It is displayed as https:// as long as I add no “slug” as soon as I add a slug the https -> http.

In Wordpress generell settings all is set to https.

Right now I just got:

https://www.feedvalidator.or

Server returned HTTP Error 301: The HTTP server returned a redirect

error that would lead to an infinite loop. The last 30x error message
was: Moved Permanently [help]

line 1, column 0: XML parsing error: <unknown>:1:0: no element found

Any ideas how I could fix the feeds?

¹ https://www.immerda.ch/info/2018/09/04/mehr-mehr-ssl.html


#2

Check Podlove > Expert Settings > Website Protocol (last setting). If your WordPress is setup correctly, this should be set to “hands off”, otherwise you can try option 2, forcing https.


#3

Vielen Dank @ericteubert. Das hat das Problem tatsächlich gelöst.