[SOLVED] Cover Art URL only gets delivered in HTTPS (which Apple Podcast-Connect doesn't like)

Hi,

my main Domain is secured with SSL but I use a non-SSL Sub-Domain for delivering MP3/Images. But even when I set the Cover Art in the Podlove Setting directly to my URL (instead of uploading it to the Wordpress Library first) like so:

http://media.gamedevpodcast.de/logo_2800.png

The feed is getting a HTTPS-URL (which Apples Podcast-Connect can’t read because my certificates coming from Let’s Encrypt):

<itunes:image href="https://gamedevpodcast.de/wp-content/cache/podlove/ea/5cfbe32845550169506dc9aa92c22b/game-dev-podcast_original.png"/>

It looks like the Wordpress-Cache makes trouble. Unfortunately I don’t have any cache Plugin installed and don’t know how to disable the Cache.

Does anyone have an idea how to solve this?

Lösung:

Dem Ordner

/wp-content/cache/podlove/ea/5cfbe32845550169506dc9aa92c22b

jegliche Schreib/Lese-Rechte entziehen. Vorsicht: Nicht einfach dem ganzen Podlove-Ordner die Rechte entziehen, denn dann wird z.B. auch nicht mehr das Podcast-Logo im Web-Player dargestellt.