[solved] Player doesn´t find any Assets though recognized in backend

Dear friends of Podcasting,

I am trying to set up Podlove for hours and don´t get my MP3 file to play.
I followed the video instructions, I set up all the assets, I uploaded my MP3 in a custom named folder ‘podcasts’ in directory path ‘/home/MYINSTALL/public_html/wp-content/uploads/podcasts/’. I then set up my media path in the options as


This is what happens: I can reach the MP3 on the server, it plays just well. Also, the file is well received in the Podcast template, it´s given green light being recognized, I can even calculate its length there by clicking the button, and if I click the proven (bluish) link in the podcast template (just like in the video tutorial!) it all works fine! I can reach the file and play it in the browser.

But nevertheless, on the published podcasts I always get this when pressing PLAY: “Es konnten keine Audio Dateien vom Server geladen werden. Entweder du hast gerade keine Verbindung zum Internet oder die Dateien sind nicht auf dem Server verfügbar.”

I tried without the extra Player installed – as I understood it should work out of the box and automatically insert a functioning player, but the above mentioned failure stays persistent no matter what.

When I try with the other extra player plugin installed, the exact same error occurs.

I am guessing it has to do with my media path…maybe I am missing something?

Also, when trying to download the file in the player by the Icon/ Button it gives me a funny link like: ‘https://domainname.cl/podlove/file/1/s/webplayer/c/episode/nameofmy.mp3’.

I see no connection by any means between this link structure and the media path I set up. Might this be the problem? And how would I solve it!

Also, in the Debug in the plugin settings it seems that my file is trying to be grabbed with a second ‘.mp3’ at the end. ‘http://mydomain.cl/wp-content/uploads/podcasts/nameofmy.mp3.mp3’ I am trying to find out where this could happen in Podlove, as the original file dows not have this problem in its title!

Thanks for any insights, I really love the plugin, the appearance and the player interface. Best thing out there! Just cannot get it to work!


Hey there everyone,

after a lot of fiddling and a very nice reply in the Wordpress forum I was able to solve it! I guess I won´t be the last one, so I want to let you know that deactivating TRACKING solved my problem.

I actually mistook the option ‘Bei Verifizierung von Assets SSL-Peer-Überprüfung verwenden.’ for the tracking option. Somehow I completely overlooked the Tracking tab above the fold!

I have been playing around a lot with the plugin, it has a stepp learning curve and is a lot of fun!

Thanks a lot!

1 Like