[solved] Podigee web player on https website


#1

When I heard, the Podigee web player would be included in Podlove 2.4, I was very glad, because I think its embed feature is a real nice and long-missed feature for podcast players.

On the Resonator’s webpage I’d like to change to the Podigee web player. Our website ist https and we are running the Twentysixteen Design by Wordpress. On Windows computers this works out perfectly fine in all commons browsers. On macOS and iOS however, there’s a turning wheel turning and turning, but the Podigee webplayer doesn’t appear. This happens in Safari and Chrome.

I asked @benzimmer about it. And he says, the problem is not on his side. Can you help, @ericteubert or someone from the webplayer team? Thanks!

Furthermore, for testing this, it would be nice to be able to specify the weplayer in the [podlove-episode-web-player] shortcut. So I could set up a test page with the podigee player without changing the default player (cutting off all macOS and iOS users).


#2

Problem seems to be that although the website is served through https the configuration URL for the player is http. This prevents the player from loading the configuration.


#3

Are both your “WordPress Address” and “Site Address” in WordPress “General Settings” (/wp-admin/options-general.php) set to https?


#4

Thanks, @ericteubert. That did it!

/cc @benzimmer


#5

How do you activate the podigee web player?


#6

Podlove -> Podcast Settings -> Player