Standalone Wordpress plugin update?


#21

Die Settings-Seite bleibt beim Aufruf auch leer:
/wp-admin/options-general.php?page=podlove-web-player-settings


#22

Da scheint noch was bei der Installation zu klemmen :confused: Lokal hat das alles funktioniert. Was fĂŒr eine Wordpress Version verwendest du? Der Player kann gerade auch nicht die Kapitel per json auflösen. Da muss ich noch nacharbeiten.


#23

Die aktuelle 4.9.5 - Installation hier durch 1:1-Kopie ins Plugin-Verzeichnis, Ownership und Rechte aller Files stimmen. Ich kann das gerne mal eine halbe Stunde aktiviert lassen, falls Dir das was von außen bringt.


#24

So, jetzt nochmal auf die offizielle Art installiert. Per Wordpress-eingbautem Uploader. Jetzt funktioniert die Settings-Seite, aber der Player erscheint immer noch nicht.


#25

So, gehe jetzt schalfen, habe den alten Player wieder aktiviert.

Die Settings-Seite sieht echt gut aus!


#26

Ist ja schonmal was. Kannst du mir irgendwie Testdaten zukommen lassen. Bspw, die typischen embeds die du so machst. Richtig genial wÀre es wenn ich eine Instanz duplizieren könnte.


#27

Unser Standard-Embed sieht so aus:

[podloveaudio src="http://www.podtrac.com/pts/redirect.mp3/happyshooting.podzilla.de/hs553_schwanmuetze.mp3" chapters="http://happyshooting.podzilla.de/hs553_schwanmuetze.psc.json" chaptersVisible="true" progress="true"]

aber selbst wenn ich es aufs nötigste runterstrippe wird der Player nicht angezeigt:

[podloveaudio src="http://www.podtrac.com/pts/redirect.mp3/happyshooting.podzilla.de/hs553_schwanmuetze.mp3"]

Kannst Du vielleicht aus der Page source sehen, ob es da evtl. irgendwelche Konflikte gibt? Wenn Du mir rechtzeitig bescheid gibst, kann ich den Beta-Player mal fĂŒr begrenzte Zeit auf unserer Live-Instanz aktiviert lassen.


#28

Hast du das andere Plugin deaktiviert?


#29

Ja, war wÀhrend des Tests deaktiviert.


#30

Ich werde leider erst ĂŒbernĂ€chste Woche wieder dazu kommen etwas weiterzuentwickeln :confused:


#31

Ich habe es auch mal versucht (WP-Version:4.9.1) und kann bestÀtigen: Die Settings-Seite sieht wirklich gut aus. Sogar mein Podcast-icon konnte ich dort speichern und sehen. Mit o.a. Shortcode in den einzelnen BeitrÀgen war der Player dann leider noch nicht ersichtlich.


#32

So ich bin wieder im Lande und habe mal den minimalen shortcode probiert und das funktioniert bei mir. Ich habe das GefĂŒhl das sich das alte und das neue Plugin irgendwie beharken :face_with_raised_eyebrow:

image

image


#33

Auch wenn man das alte deaktiviert?


#34

31


#35

Auf was fĂŒr einer PHP Version lĂ€uft dein Wordpress?


#36

Bin jetzt einen Schritt weiter. Player erscheint mit PodcastEpisodenBild in der Vorschau zum Beitrag. Es kommt die Meldung im Player:
“Zum Abspielen des Podcasts fehlen die Referenzen zu den Audiodateien”

16

Gebe ich die “bisherigen” Befehle ein, verschwindet der Player wieder in der Vorschau zum Beitrag.

Wo kann ich die benötigten Informationen eintragen?
Wie lauten die Befehle um die benötigten Referenzen im Beitrag (Titel, Untertitel, Dauer, Kapitel, Informationen) per shortcode zuzufĂŒgen?
Ist das irgendwo in den Einstellungen machbar (so wie mit dem Podcast Bild?
Danke


#37

Ahh sehr interessant, das was du siehst ist gerade noch ein bug, kannst du mir den shortcode den du verwendest mal posten?


#38

Per Message erfolgt.


#39

@spikedih @chrismarquardt so hier ein weiterer Versuch: https://we.tl/mLUKz6VFE1


#40

Mag immer noch nicht, Player wird nicht angezeigt. Habe auf zwei Systemen getestet.

Eines der Systeme lÀuft auf PHP 5.4.40, das andere auf PHP 7.0.29