Testing in local

Hi guys,

I’m new to Podlove. :smiley:

I just downloaded Podlove Publisher on the WP repo and try to test il locally (using Local by Flywheel).
I filled all the necessary fields, uploaded a media file in the WP media library of my local website and created an episode but the player doesn’t work.

I have 2 messages that might help to explain the problem:
1- in the back office, on the episode page, the “Media file” section says “File not found!” with a red cross. However, when you click on the “file url” value, it works perfectly and it can also detect duration of the track.
2- in the front, the player itself is in black mode and says:
“The Player received an invalid configuration. Without media files, the player can’t be used. Please reach out to the host to fix this problem.”

I’m pretty sure I’ve set up everything correctly so my question is: is it supposed to work on local websites?

Thanks for your help on this! :slight_smile:


Laurent

I don’t know how “Local by Flywheel” is setup. What you describe in 1) happens if the file URL is actually reachable but the backend server cannot resolve it, for example due to DNS issues. That may be an issue with your local setup.

In general, if the displayed file URL is correct, you’ve setup Podlove Publisher and the episode correctly.

Thanks for your answer, Eric.

Actually, I tested with 2 different audio file locations:

And the result was the same for both with the same error message displayed.

atej

Laurent

I just gave flywheel a try and setup Publisher on a fresh WordPress with the episode you provided and it worked. I recorded myself doing it, maybe that is helpful for you.

Hi @ericteubert

First of all, let me thank you for taking the time to do the install and record your screen.
I really appreciate it :pray:

So I setup Publisher on a fresh WordPress too and did exactly what you did and oh magic, it worked.

So I started thinking that the problem could be caused by a conflict between Podlove and another plugin. So I deactivated/reactivated each other plugin one by one to identify the bad sheep but I couldn’t figure it out.

Would it help if I share with you the error messages I have on the Support section of the Podlove plugin?

ERROR MESSAGE

2019-12-20 12:14:03 All assets for this episode are invalid! Title

WARNING MESSAGE

2019-12-20 12:20:49 Curl Error: SSL certificate problem: unable to get local issuer certificate electricguest_under-the-gun/MP3 Audio toggle details
2019-12-20 12:20:50 Unexpected http response when trying to access remote media file. electricguest_under-the-gun/MP3 Audio HTTP Status: 0 toggle details
2019-12-20 12:20:50 Curl Error: SSL certificate problem: unable to get local issuer certificate electricguest_under-the-gun/MP3 Audio toggle details
2019-12-20 12:20:50 Unexpected http response when trying to access remote media file. electricguest_under-the-gun/MP3 Audio HTTP Status: 0 toggle details
2019-12-20 12:20:50 Can\'t reach https://laradiostation.fr/wp-content/uploads/audio/electricguest_under-the-gun.mp3 HTTP Status: 0 toggle details

And when I click on one of the toggle details links, here is what it says:

---
media_file_id: "1"
http_code: 0

---
url: >
  https://laradiostation.fr/wp-content/uploads/audio/electricguest_under-the-gun.mp3
content_type: null
http_code: 0
header_size: 0
request_size: 0
filetime: -1
ssl_verify_result: 20
redirect_count: 0
total_time: 0.031107
namelookup_time: 0.000707
connect_time: 0.01856
pretransfer_time: 0
size_upload: 0
size_download: 0
speed_download: 0
speed_upload: 0
download_content_length: -1
upload_content_length: -1
starttransfer_time: 0
redirect_time: 0
redirect_url: ""
primary_ip: 213.186.33.3
certinfo: |
  Array
  (
  )
primary_port: 443
local_ip: 192.168.1.19
local_port: 55819
http_version: 0
protocol: 2
ssl_verifyresult: 0
scheme: HTTPS
appconnect_time_us: 0
connect_time_us: 18560
namelookup_time_us: 707
pretransfer_time_us: 0
redirect_time_us: 0
starttransfer_time_us: 0
total_time_us: 31107
php_open_basedir: ""
php_curl: true
curl_exec: true

Having talked to Alexander (the dev) in the recent weeks, I know that you are actively working on the v5 player.

Do you have an ETA?

If you release it soon, maybe it’s a loss of time for me (and you) to try to understand the problem I have now.

Cheers,


Laurent

I’ve just done 2 additional tests.

  1. On my fresh install, I went to “Local by Flywheel” to switch the domain from http to https and updated the urls in the settings => Podlove kept working as planned.

  2. I did a new fresh WP install but this time, I set up the https before uploading Podlove and creating my first episode => Podlove no longer worked as planned.

If you still have the install you made 2 days ago, could you do test #1 by:

  • activating the SSL certificate in “Local by Flywheel”

image

  • and go from http to https in the WP Settings > General.

Then, could you do my test #2 and see if it still works fine?
I have the feeling that it won’t.

Best,


Laurent

Hi @ericteubert. I didn’t tag you in my last posts, so I don’t know if you noticed them.

Best,

Laurent

Hi @laurentf and @ericteubert

I have the same problem. And i also did what you did with the under-the-gun file. But here, that didn’t help at all. Same error in the web-player. I removed all plugins but the publisher. And yes, my wordpress is fresh as it can be. I checked the log and here i have this:

Can’t reach https://laradiostation.fr/wp-content/uploads/audio/electricguest_under-the-gun.mp3.mp3 HTTP Status: 404

It seems, for some reason, the file extension get’s added twice. Does someone know why? I’m sure, the slug for this file is correct -> without the .mp3

Does anyone know what the reason could be? I should add, I have absolute no experience with podcasting and wordpress at all… but thanks to everyone who could help me here…