Analytics results in episode download error


#1

When I activate Tracking URL Parameters & Analytics episode downloads fail. Neither my podcast app, nor Podlove Webplayer finds the asset anymore.
(New installation of current WP and Podlove versions)

Any ideas?


#2

Please post the debug section of the tracking settings page and the text under “Podlove > Support”.


#3

“Debug Tracking” is empty. Here are the system details:

Website                    http://14049714fcfa473895807f39fde36221.testurl.ws
PHP Version                7.1.13
WordPress Version          4.9.5
WordPress Theme            Twenty Seventeen v1.5
Active Plugins             
           - Podlove Podcast Publisher v2.7.4
WordPress Database Charset utf8
WordPress Database Collate 
Publisher Version          2.7.4
Web Player Version         player_v4
Twig Version               1.35.3
open_basedir               ok
curl Version               7.38.0
iconv                      available
simplexml                  ok
max_execution_time         180
upload_max_filesize        128M
memory_limit               256M
disable_classes            
disable_functions          
permalinks                 ok (/blog/%year%/%monthnum%/%day%/%postname%/)
podlove_permalinks         ok
podcast_settings           ok
web_player                 ok
podlove_cache              on
assets                     
  - mp3    audio/mpeg       http://14049714fcfa473895807f39fde36221.testurl.ws/feed/mp3/
cron                       ok
multisite                  ok

0 errors
0 notices
Nice, Everything looks fine!

#4

Is your mp3 asset configured as “downloadable”?


#5

It wasn’t. Changed it and now it works. Thanks!
Is that the expected behavior?


#6

Yes, but maybe the setting should be renamed to “publicly acessible” or something more generic, since it affects all access.

And possibly a warning if there are no downloadable assets at all.

/edit: after an internal discussion it turns out that’s not how it was intended. Future versions of this setting will only affect download user interfaces, not the actual ability to access the file.


#7

Makes sense. FYI, everything was working fine with tracking disabled. But that might have been just because my assets are in the WP upload folder.