Audacity chapter marks import

I created chapter marks in audacity and exported them as txt file.
I tried to upload it into the publisher but nothing happens. No error and no chapters in my podcast.
One line in the file looks like this:
3,887288 3,887288 Vorstellung

can you provide the complete file as an attachment?


Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, ico, pdf).

well then paste it here

    3,887288	3,887288	Vorstellung
    26,076089	26,076089	Thema: Antivirus
    86,408925	86,408925	On Access Scanner
    236,415633	236,415633	Verhaltensanalyse
    280,959691	280,959691	Security Suite
    629,031700	629,031700	Firewall & offenes WLAN
    723,018863	723,018863	WLAN Inspektor
    810,349712	810,349712	Webschutz
    1130,598325	1130,598325	Passwortmanager
    1333,655861	1333,655861	Browser Cleaner
    1419,375882	1419,375882	Sandbox
    1458,774609	1458,774609	Kostenlose Alternativen
    1568,543894	1568,543894	Software Updater
    1675,670623	1675,670623	Antispam
    1875,679567	1875,679567	Vor was ein AV nicht schützt
    2050,394515	2050,394515	Ransomware
    2175,053977	2175,053977	Zusammenfassung

Thanks. I found the problem.

Your files are using , (comma) as a delimiter while the specification only defines . (dot). The Podlove Publisher only supports the spec. I guess Audacity is somehow using the system locale settings which define , as a decimal delimiter when exporting the label track.

So the quick fix is changing the comma to dot. The overall fix is to make Audacity conform to its own spec, possibly by tweaking settings or complaining about the mistake to the developers.

@ericteubert: Of course, we could accept , too to cover these cases. What do you think? Also, the feedback when importing a file with a wrong syntax should be more explicit (e.g. say something at all).

1 Like

The problem still persists :slight_smile:
Of course it could solve this for me but there is still no message shown and commas are also not accepted.

I fixed the comma issue in the parser and it will be included in Publisher 2.7.0.

1 Like