Episode player doesn't work on mobile

I have an issue with the player on mobile (I tried Safari, Chrome and Firefox on an iPhone). While a manually embedded player with an mp3 media file works fine, an automatically embedded episode player produces an error.

When I try to download an asset from the player, it gets an html file instead of the media file.

Trying to open this download URL, I’m getting this error:

Misdirected Request

The client needs a new connection for this request as the requested host name does not match the Server Name Indication (SNI) in use for this connection.

Turning off tracking solves the download issue but not the episode playback issue.

No issues on desktop. The player is embedded via CDN.

Any idea what’s causing this?

Can you provide an URL so I can have a look? Also in most network error cases a misconfigured webserver is the root error source. Would also explain the trailer01.m4a.html download response.

I tried various things, including deleting the subdomain that serves the assets and its folder on the server and recreating it in a different location. It hasn’t improved.

However, I noticed that the same issue occurs, when you try to play the episode through the Google Podcasts website. It works on a desktop browser and fails on mobile. So it seems unrelated to the web player. Could it be a Publisher issue, @ericteubert?

A URL to the website in question would really be helpful.

It seems to be working now, and was probably indeed a certificate issue. I switched the asset location to an entirely different domain now and that solved it.

1 Like