Fatal Error seit Update


#1

Hallo Zusammen,

mich plagt seit Kurzem ein Fehler, der offenbar auf Podlove zurückzuführen ist. Verändert habe ich nichts, laut einem Nutzer soll der Feed seit einigen Tagen nicht richtig angezeigt werden. Das konnte ich reproduzieren, sowohl für den globalen, als auch für den Podcast-Feed. Etwas Recherche brachte die Erkenntnis, dass das Problem von Twig herzurühren scheint. Folgendes steht unter dem Feed:
55 Fatal error: Declaration of Twig_Extensions_TokenParser_Trans::parse(Twig_Token $token) must be compatible with Twig\TokenParser\TokenParserInterface::parse(Twig\Token $token) in /www/htdocs/wxxxxxxx/wordpress/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/vendor/twig/extensions/lib/Twig/Extensions/TokenParser/Trans.php on line 0

Dieser Fehler wird auch auf der Webseite angezeigt und beendet offenbar die Feed-Ausgabe ab dem Moment, wenn eine Podcast-Episode angetriggert wird. Lösche ich die aktuellste, werden dann die normalen Feeds bis zum Podcast angezeigt, sowohl im Feed, als auch auf der Webseite.

Ich habe nichts großartig verändert, die Vorlage enthält:

{% if not is_feed() %}

{# display web player for episode #}
{{ episode.player }}

{# display download menu for episode #}
{% include "@core/shortcode/downloads-select.twig" %}

{% endif %}

Zwar hatte ich zuvor Kleinigkeiten an den Einstellungen verändert, die aber das Problem nicht ausgelöst haben. Eventuell ist auch ein Update fehlgeschlagen, das kann ich nicht ausschließen.

Vielleicht weiß jemand Rad, das wäre super.

Gruß Stephan


#2

Inkompatibilität mit MailPoet, Problem wurde den Plugin-Autoren berichtet https://github.com/mailpoet/mailpoet/issues/1904


#3

Sehe ich das richtig, dass es dafür noch keine Lösung gibt, außer Mailpoet abzuschalten?


#4

Das neueste MailPoet Update 3.23.0 von gestern behebt das Problem.