Feed is broken after WP- and Plugin-Updates


got a huge problem, think is has soemthing to do with the publisher.

I updated wordpress 4.9 to 5.4 yesterday and also all podlove-plugins.

Now there is an error for the player (v4), but the player is working, but I can only see a standard-player. but this is not my biggest problem right now: My feed stopped working!

I am getting on https://castfeedvalidator.com/?url=https://www.couch-entertainment.de/feed/mp3/ this errors:

FATAL: Invalid content type for feed. Did not finish feed tests.
WARNING: It took your feed 2 seconds to download.

In the Android-App “Podcast Addict” this error is shown:
“Broken RSS feed: Doesn’t look like a valide RSS feed… First Tag: br”

I don’t know where to look exactly, the properties in the publisher seems all correct and i didn’t changed anything there. Maybe it has to do with the errors of the player?

The errors of the player are this:
Warning : array_replace_recursive(): Expected parameter 2 to be an array, null given in /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186

Warning : array_replace_recursive(): Expected parameter 2 to be an array, null given in /www/htdocs/w00ceae5/wp-content/plugins/podlove-web-player/includes/class-podlove-web-player-options.php on line 186


Did you fix it? The errors seem to have disappeared.

Tried a workaround, which was suggested in the sendegate-forums.
–> https://aristath.github.io/blog/wp-hide-php-errors
Feed is up and working again, but I don’t think that’s the real solution?

searching on Google “podlove-web-player array_replace_recursive” I noticed that the problem is affecting a lot of sites.

Thanks for the report, I will have a look how to fix this.

I released v5.1.2 this ensures that the call get’s a second argument. @CouchMaster could you verify the fix?

It works.


1 Like

I will have a look in the evening.

1 Like

I updated the player and reversed the workaround in the wp-config.
No PHP-Errors and no broken feed! That is fixed.

But, I am seeing only the standard web-player, not what I configured, that’s still weird.

Glad to hear, can you switch the source to CDN? Right now the player resources points to the wrong path, which is an ongoing issue in the player. I tried to fix that several times but still fighting with the wordpress api…