Get rid of the category feed's item limit

On our site we use category feeds to diferentiate between several shows. I just noticed that those category feeds have an item limit of 20 episodes although the main feed is unlimited.

Example: category feed vs. main feed

Did I miss a setting? Is there a way to get rid of the limit so that all the episodes show up?

Thank you!

In Podlove > Podcast Feeds settings.

It’s already set to “No limit.” That’s why I’m asking. :neutral_face:

What is the setting in “Settings -> Reading -> Syndication feeds show the most recent”? Is it set to 20?

If yes, I assume Podlove Publisher somehow applies the WordPress default when categories are involved.

No, it’s set to 1000 already. Am I the only one having this problem? If so, I have to check my configuration. I did some modifications to the category feeds in my functions.php so that they contain the name and description of the category instead of the general podcast. Maybe something broke in the course of this.

Try to remove these modifications and see if it has any effect on the limit.

Huh. Not sure what I did but the problem is gone. Maybe re-submitting the podlove settings helped. I don’t know… Thanks anyway!

This topic is now closed. New replies are no longer allowed.