Iframe code does find media files (when not logged into WordPress)

If a certain episode is embedded on other sites via the iframe code from the share menue the embedded player does NOT find the corresponding media files.
Fehlende Medien Dateien

Die zur Verfügung gestellte Konfiguration ist fehlerhaft. Ohne Mediendateien kann der Player nichts abspielen.

The src string alone also raises the same error message.

https://www.geemco.de/wp-content/plugins/podlove-web-player/web-player/share.html?config=https%3A%2F%2Fwww.geemco.de%2Fwp-json%2Fpodlove-web-player%2Fshortcode%2Fconfig%2Fdefault%2Ftheme%2Fdefault&episode=https%3A%2F%2Fwww.geemco.de%2Fwp-json%2Fpodlove-web-player%2Fshortcode%2Fpublisher%2F12838

It happens also on my own site on a test page if I’m not logged into the WP backend.

The player itself on ordinary episode pages is ok, independently on the login status.

Any idea on that?

Edit: forgot the NOT in the very first sentence.

Hey,

my guess is that the API calls from the player are blocked. Do you have any “security” plugins installed that disable unauthenticated API requests?

Thanks for replying.

Yes, I do use a security plugin but I’m not blocking (REST) API calls. A deactivation of the plugin also made no difference.

It seems to work for me:

Screenshot 2021-06-24 at 19.15.05

Yes, on my own site it’s fine. But the iframe scr string in the share field is failing on other people’s sites

But chance I came across another plugin in use that barely disabled al API calls. After enabling the ones for web player shortcode everything looks good so far.

Many thanks for your hint!

1 Like

Hello,

i have the same problem.
The function for the iframe cannot load the data by the player.

Error message:

code	   "restx_logged_out"
message	"Sorry, you must be logged in to make a request."
data	
status	401

Webpage ist: https://podcast.heagmobilo.de

iframe code:

<iframe title="Podlove Web Player: Wenn möglich, bitte wenden! - Night-Heiner im HeinerLiner" height="200" src="https://podcast.heagmobilo.de/wp-content/plugins/podlove-web-player/web-player/share.html?config=https%3A%2F%2Fpodcast.heagmobilo.de%2Fwp-json%2Fpodlove-web-player%2Fshortcode%2Fconfig%2Fdefault%2Ftheme%2Fdefault&episode=https%3A%2F%2Fpodcast.heagmobilo.de%2Fwp-json%2Fpodlove-web-player%2Fshortcode%2Fpublisher%2F103" frameborder="0" scrolling="no" tabindex="0"></iframe>

We are using Wordpress 5.8.1 with

  • Disable “BIG image” Threshold 1.0
  • Podlove Podcast Publisher 3.6.0
  • Podlove Web Player 5.4.13
  • Shariff Wrapper 4.6.7
  • Wordfence Security 7.5.5
  • WP Mail SMTP 3.0.3
  • WP Test Email 1.1.4
  • WPForms Lite 1.6.9

I have already looked through everything and deactivated plugins as a test, but so far I have had no luck.
Any hint is welcome!

Where or how can I check whether the API Calls has been switched off?

Thank you for your help.
Greets, jos73

WP noobie