Issues with player not working and disabling tracking

Hey, folks.

I’m having an issue where audio doesn’t play if the listener starts from anywhere except the very beginning of the episode. Selecting a different chapter or choosing a different time stamp result in the podcast player hanging for a moment before throwing an error:
“Network error: Couldn’t load the audio files from the server. Maybe you don’t have connectivity to the internet or the Podcast host is not available.”

The logs display:

Curl Error: Operation timed out after 3000 milliseconds with 0 bytes received S1E1_A_Pair_of_Fools/MP3 Audio toggle details
2020-03-04 05:06:07 Unexpected http response when trying to access remote media file. S1E1_A_Pair_of_Fools/MP3 Audio HTTP Status: 0 toggle details
2020-03-04 05:06:07 Can’t reach HTTP Status: 0 toggle details

I tried disabling tracking, as suggested on various other posts, but now I get the same error, only immediately, and there’s no debug log entry. The file is verifying, and clicking the URL loads it immediately, but the player throws an error.

So with the tracking and analytics enabled, the episode loads from the beginning, but not from any other point.
With tracking disabled, the episode doesn’t load at all.

figured it out. It’s because of mixed content. the guy who did the site didn’t do the cert right.