Itunes error : "Can’t download episodes from your feed"


#1

I read 2 or 3 messages here that may concern this error but none corresponded to my situation.

I use Wordpress with the Podlove plugin (see the settings at the end of the message).

My mp3s are hosted on an AOD service via my infomaniak website host.

My RSS feed is validated by http://castfeedvalidator.com/?url=https://www.les-sensibles.fr/feed/mp3/

When I subscribe to my podcast in Itunes using this feed, it works. I see my audios and their summary appear and can listen to my 4 episodes.

But when I want to submitt my podcast, I still have the same error message.

It’s been days since I’m looking for where the error comes from. I wrote to Itunes yesterday and I’m waiting for an answer …

I hope someone can guide me.

Website https://www.les-sensibles.fr
PHP Version 7.0.16
WordPress Version 4.8.3
WordPress Theme Divi Child v1.1
WordPress Database Charset utf8
WordPress Database Collate
Publisher Version 2.6.2
Web Player Version 2.1.1
Twig Version 1.33.2
open_basedir ok
curl Version 7.26.0
iconv available
simplexml ok
max_execution_time 60
upload_max_filesize 300M
memory_limit 640M
disable_classes
disable_functions set_time_limit, passthru, exec, system, popen, shell_exec, proc_open
permalinks ok (/% postname% /)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
assets

0 errors
0 records
Nice, everything looks fine!


#2

Not sure why that is, but I took a look at your download forwarding chain.

The first redirect looks like it should. This delivers the 301 redirect for Analytics counting and should not confuse the iTunes directory:

tim@eris % curl -I https://www.les-sensibles.fr/podlove/file/19/s/feed/c/mp3/episode-3.mp3                                                                              ~
HTTP/1.1 301 Moved Permanently
Date: Tue, 07 Nov 2017 22:56:33 GMT
Server: Apache
Vary: Cookie
Location: https://vod.infomaniak.com/redirect/axellelazewski_vod/podcastsensiblerevolution-41064/mp3-476/episode-3.mp3?ptm_source=feed&ptm_context=mp3&ptm_request=c371e61b4f77&ptm_file=episode-3.mp3
Content-Type: text/html; charset=UTF-8
Strict-Transport-Security: max-age=16000000; includeSubDomains; preload

Podlove Publisher has now delivered the “direct” link to the media file as configured which now points to the vod.infomaniak.com server.

Accessing this URL does not yet deliver the media file immediately however:

tim@eris % curl -I "https://vod.infomaniak.com/redirect/axellelazewski_vod/podcastsensiblerevolution-41064/mp3-476/episode-3.mp3?ptm_source=feed&ptm_context=mp3&ptm_request=c371e61b4f77&ptm_file=episode-3.mp3"
HTTP/1.1 302 Found
Date: Tue, 07 Nov 2017 22:56:48 GMT
Server: Apache
Cache-Control: no-cache, must-revalidate
Location: https://str17.infomaniak.ch/dl/28aebbacb4fd2dc64658d95596a0c091/5a023a30/axellelazewski_vod/1/d/episode-3.41064.476.mp3?ptm_source=feed&ptm_context=mp3&ptm_request=c371e61b4f77&ptm_file=episode-3.mp3
Connection: close
Content-Type: text/html

So your server does another redirect here using “302 Found”. I am not sure this could be something that confuses the iTunes Directory.

The final step is fine:

tim@eris % curl -I "https://str17.infomaniak.ch/dl/28aebbacb4fd2dc64658d95596a0c091/5a023a30/axellelazewski_vod/1/d/episode-3.41064.476.mp3?ptm_source=feed&ptm_context=mp3&ptm_request=c371e61b4f77&ptm_file=episode-3.mp3"
HTTP/1.1 200 OK
Content-Type: audio/mpeg
Accept-Ranges: bytes
ETag: "2072025788"
Last-Modified: Fri, 27 Oct 2017 08:35:05 GMT
Content-Length: 13561032
Date: Tue, 07 Nov 2017 22:57:15 GMT
Server: lighttpd

So if you have control over the vod.infomaniak.com server I wonder if you could change the “302 Found” redirect to a “301 Moved Permanently” and test if this changes the behaviour of the iTunes Directory.


#3

Thank you very much for your fast answer :slight_smile:

Today ITunes replied that my .mp3 files were not valid and that I had to encode in AAC (.m4a). I did it. But that did not solve my problem. I always have the same mistake when submitting my podcast to Itunes.

I think you are right because I found this in Podlove / Support / Debug Logging:
2017-11-08 17:05:12 Unexpected http response when trying to access remote media file. episode-1 / M4A Audio HTTP Status: 400

Unfortunately, I can’t access to my webhost’s server and anyway if it’s not a big deal for a coder ; for me, it’s far away from my skills limits :cold_sweat:
I suppose there is a wrong setting about the https either in the Podlove plugin or in the plugin that manages the https (Really Simple SSL pro).
I still spent the day trying different tests without success.

If I pay for a Podlove support, will someone be able to to check and correct these settings directly on my wordpress dashboard ? And explain to me after because I like to understand and improve :wink:
Or if you know someone else who could help me (I will pay him/her of course), do not hesitate to tell it to me.

Thanks a lot


#4

Sure, there is professional support available for Podlove Publisher:

https://publisher.podlove.org/support/

That’s also a good “insurance” if you ask me :slight_smile:


#5

Had the same error yesterday because of (white)spaces in the filenames: “XYZ - 123” did not work. Renamed to (removed spaces) “xyz-123” and it worked like a charm.

Edit: just saw the links with the file names above and they do not contain spaces. Nevermind.


#6

Hello @Tim, I contact you via the professional support. I hope my problem will be solved quickly!


#7

Thanks @Fabian. It’s helpful to know that anyway. It could help other people. Have a nice day :slight_smile:


#8

@AxelleL I just ran into the same problem. Did you ever find a solution?

/edit: As a temporary workaround I checked the box “Allow to skip feed redirects” in the Expert Settings and added “?redirect=no” to my feed URL.


#9

Hello Sascha, yes everything works perfectly. But I’m sorry, I don’t remember how the problem was solved. I used podlove’s paid support.