Open Basedir workaround


#1

after updating the page from http to https there is a strange error. the old episodes are working fine the new ones arent loading and if u click on “download” you will be redirected to the Homepage.

any ideas?

Website https://bildung-verquer.de/radio
PHP Version 7.0.30-0+deb9u1
WordPress Version 4.9.8
WordPress Theme Agility Child Theme v2.0
Active Plugins
- Broken Link Checker v1.11.5
- Comments Disable - AccessPress v1.0.4
- Contact Form 7 v5.0.3
- Display Widgets v2.7
- Duplicate Post v3.2.2
- Image Widget Deluxe v1.0.6
- Instant Images v3.2
- MapFig Leaflet Plugin v4.0.7.2
- Podlove Podcast Publisher v2.7.9
- Podlove Subscribe Button v1.3.3
- Podlove Web Player v2.1.0
- Post Type Switcher v3.1.0
- Redirect 404 Error Page to Homepage or Custom Page v1.4
- Remove/hide Author, Date, Category Like Entry-Meta v2.1
- Shariff Wrapper v4.5.2
- SSL Insecure Content Fixer v2.7.0
- The Events Calendar Shortcode v1.9
- The Events Calendar v4.6.21
- Cookie Consent v2.3.11
- Wordfence Security v7.1.10
WordPress Database Charset utf8
WordPress Database Collate
Publisher Version 2.7.9
Web Player Version player_v2
Twig Version 1.35.3
open_basedir /home/bildung-verquer/public_html/:/tmp/:/usr/share/php/
curl Version 7.52.1
iconv available
simplexml ok
max_execution_time 120
upload_max_filesize 32M
memory_limit 128M
disable_classes
disable_functions exec,passthru,shell_exec,system
permalinks ok (/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
assets

0 errors
1 HINWEIS (no dealbreaker, but should be fixed if possible):

  • The PHP setting “open_basedir” is not empty. This is incompatible with curl, a library required by Podlove Publisher. We have a workaround in place but it is preferred to fix the issue. Please ask your hoster to unset “open_basedir”.

the hoster says there is no way to change open basedir, so whats the workaround? =)


#2

I don’t think it has anything to do with the open_basedir setting.

Possibly play with the “Check for Assets with SSL-peer-verification.” setting in expert settings, that may help.


#3

checked or unchecked it didnt work…
the strange thing is its also not works if i use the direct link to the file after i upload via ftp (old files still working)