Pod web player doesn't play mp3 file


for some reason the web player doesn’t play the podcast files ( mp3 )…

i try all of them but none of seems to work… from the looks of it he doesn’t seem to find the mp3 file…

since the player v3 has a download button i saw that the url points in the wrong directory

all the mp3s are in here https://my-fish.org/wp-content/podcast/myfish-podcast-88.mp3

so how can i tell the web player to use the right directory ?

@jay: you have several distinct factors contributing here.

First, under ‘Dashboard > Podlove > Podcast Settings > Media’ you set the full URL of your MP3’s location. That is where you have to upload them to and where the WebPlayer and the PodLove Plugin are going to look for them. Period.

Then you have the PodLove Plugin that alters that very URL for the downloads it offers and serves, so it can distinct the various ways to get your assets (for the analytics page), like from the WebPlayer itself, the Download Button, the feed, etc etc. So your Download Button is actually not necessarily pointing to the wrong location.

And then there still is ‘Dashboard > Settings > Media’ where you can have WP’s media lib to optionally be organized by folders for years & months. If you happen to upload your MP3s using WPs ‘Dashboard > Media’ that will affect your paths as well.

I myself am having my PodLove assets in a separate folder outside of WP and I have Auphonic upload all assets to that - works great for me.

For a quick check of matters, when you open an episode for edit and you go down the page to the list of assets, can you then ‘update all media files’ and ‘detect duration’? That should tell you whether the files are indeed where PoldLove is told they were.

HTH, weHe!