Podlove Button not rendering anymore?


#1

I suddenly get this message in the console. Didn’t change anything on my theme etc.


VM91 app.js:5 Uncaught TypeError: $ is not a function
    at t.iframe (VM91 app.js:5)
    at t.renderButtonIframe (VM91 app.js:5)
    at t.init (VM91 app.js:5)
    at t.extractPodcastDataFromJson (VM91 app.js:5)
    at t.getPodcastData (VM91 app.js:5)
    at new t (VM91 app.js:5)
    at HTMLDocument.t.init (VM91 app.js:5)

Anybody have the same issue? Is there a fix?

I am using the shortcode to place it

[podlove-subscribe-button button="halbe-katoffl-subscribe" size="big" language="de" buttonid="halbe-katoffl-subscribe"]

In the backend the setup hasn’t changed either.


#2

Fixed it… needed a new jQuery included in functions.php
Strange that it worked before. Maybe some update changed minimal requirements?


#3

Hi MaxZ

I too am getting the “$ is not a function” error.

When you say you needed a new jQuery included in the functions.php.

Do you mean you had to add a different jQuery version instead of the default that WordPress adds?

Thanks


#4

Exactly. I added it using the function.php but you can also use something like the great “Snippets” plugin.

Here is a simple guide to replace the default jQuery with a google hosted version. You can also reference a local version in your theme folder. The thing is to deregister the given jQuery.

Hope this helps!