Podlove Webplayer not showing

I’ve been debugging this locally for a while disabling various other plugins and switching to Twenty Fifteen, but cannot seem to find the reason why the podlove webplayer shortcode is not rendering on the episode page. The episode downloads shortcode works fine. Any ideas what I might be missing here?

Website             http://localhost:8080
PHP Version         7.0.15
WordPress Version   4.7.2
WordPress Theme     Twenty Fifteen v1.7
Publisher Version   2.4.5
Web Player Version  2.1.1
Twig Version        1.30.0
open_basedir        ok
curl Version        7.38.0
iconv               available
simplexml           ok
max_execution_time  30
upload_max_filesize 2M
memory_limit        256M
permalinks          ok (/%category%/%postname%/)
podlove_permalinks  ok
podcast_settings    ok
web_player          ok
podlove_cache       on
  - mp3    audio/mpeg http://localhost:8080/feed/sell-online/
cron                ok

0 errors
0 notices
Nice, Everything looks fine!

Looks like it should work.

Which player are you using? (“Podlove > Podcast Settings > Player”)
How do you embed the player? (By default it is included via Podlove Template, see “Podlove > Templates”)

I’ve tried all 3 available players to no avail. Right now I use the short codes instead auf automatic insertion, but even if I use the default template and insert automatically it only inserts the download menu and not the player. Not sure how to debug this any further.

I’ve now disabled all plugins and tried with Twenty Seventeen, still does not work. Very strange. When I enable debugging in wp-config.php and go to the podcast settings page I get the following messages:

playerv3theme in /var/www/html/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/settings/podcast/tab/player.php on line 20

Notice: Undefined index: podigeetheme in /var/www/html/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/settings/podcast/tab/player.php on line 20

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/settings/podcast/tab/player.php:20) in /var/www/html/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/settings/podcast/tab/player.php on line 26

Not sure if this is related to my issue.

In production I’m on PHP 5.6.28, locally on PHP 7.0.15 as already indicated above.

If you go to http://localhost:8080/wp-admin/admin.php?page=podlove_settings_settings_handle&podlove_tab=web-player, is the mp3 asset assigned there? (should happen automatically).

It wasn’t and that actually did the trick! At least for the selected episode.

Any ideas why it still doesn’t work for the previous episodes? I’m not sure if I still have a general misunderstanding about podcast episodes and assets in podlove …

Have a look at the dashboard. The asset ist listed for all episodes but the episodes need to “see” it. You can go the Episode Asset menu, hover over the asset and select the “Activate for all existing Episodes” entry.

Watch https://www.youtube.com/watch?v=Hmrm-jUe6u4 if you haven’t already, it goes through all the basics.

1 Like

Thanks for pointing me to the video, which cleared my main misunderstanding about how Podlove works. I thought I need to create one asset for each podcast episode and have to assign that asset to the episode custom post.