Release 2.6.1


#1
  • fix template bug (when a template returned an empty result, the template title was displayed instead)

Flattr

  • rename “Flattr Username” to “Flattr ID”
  • insert flattr:id meta tag to page heads, which is required for their new system

#2

Hallo Eric,

vielen Dank für die neue Version. Leider behebt sie ein Problem nicht, dass ich seit der 2.6.0 beobachte: Ich habe den neuen Webplayer 4 aktiviert und auf unserer Podcast-Folgen-Seite (http://fotophonie.de/audiocast/) befinden sich nun alle Player am Kopf der Seite. Nicht mehr jeder Player am Anfang der jeweiligen Episode auf der Seite.

Ich weiss, der neue Player ist noch alpha. Liegt das Problem daran, oder an etwas anderem? Also, soll ich als Webplayer lieber die Version 2 verwenden, oder muss ich was anderes ändern? Ich find den 4er Player soweit schon sehr gut und würde ihn gerne benutzen. Ein kleines Umbruchproblem hat er noch, bei langen Sendungstiteln.

Beste Grüße,
Dieter


#3

Num, das ist das was “alpha” bedeutet: nicht fertig und auch nicht feature complete.

Wir sind dankbar für alle Rückmeldungen und wir versuchen im nächsten Release schon Verbesserungen drin zu haben.

Aber wenn es richtige Probleme gibt dann ist ein Umscahlten auf die 2 die empfohlene Maßnahme


#4

Danke Tim. Mir ist schon klar was Alpha bedeutet. Mir war nur nicht klar, ob der beobachtete Effekt eben am Player und seinem nicht ganz perfekten Alpha-Zustand liegt, oder möglicherweise an etwas anderem.


#5

Vielen Dank für das teilen des Problems, ich hatte bisher leider keine Instanz zum nachstellen. Es sieht so aus als ob alle Player auf ein und die selbe DOM node (#player) registriert werden. Das sieht nach einem Fehler im publisher aus.


#6

Podlove Publisher 2.6.2 sollte einen Fix haben. Sollte jetzt verfügbar sein.


#7

Das war wohl dieses GitHub Issue. Ich war auch davon betroffen. Danke für den Fix!


@fotophonie In der mobilen Ansicht scheint da trotzdem noch was komisch zu sein.


#8

Bekannter bug, sollte behoben sein wenn der nächste alpha release kommt.


#9

Wohl der?


#10

Genau der


#11

Manchmal fehlt der Player jetzt aber komplett. Dann hilft hin und wieder ein Reload der Seite auf der der Player fehlt. Passiert vor allem bei mobilen clients (Test mit iPhone 6 und iPad Air 2 ausgeführt, beide iOS 10).


#12

Ok, da schau ich gleich mal rein. Vielen Dank das du den Player solange zum testen auf der Seite lässt.

Sehe gerade das du den Player gleich auf der Seite teaserst, das freut mich sehr :slight_smile: Hier gibts übrigens immer die neuste developer preview: http://podlove-player.surge.sh Und hier ein Player mit voll ausgebauter Funktionalität (http://podlove-player.surge.sh/standalone)


#13

Das mache ich doch sehr gerne. Ich möchte ja, dass der neue Player gut wird und sich möglichst zügig von Alpha zu Release entwickelt. :slight_smile:

Danke für die Links, aber ich glaube ich bin zu unwissend was dieses Thema angeht, als dass ich mir dort etwas abholen und selber einbauen könnte.

By the way: Abhörgeschwindigkeit im Webplayer einstellen können finde ich ziemlich cool!


#14

Muss ich mir eigentlich Sorgen darum machen, dass im Podlove-Systembericht steht “no web player found”?


#15

Nein, das ist ein Fehler im Reporting.