Release 2.7.5


#1

Preparation for GDPR/DSGVO

If you are using Podlove Publisher Tracking/Analytics, an update to this version is highly recommended.

Tracking uses a request_id to be able to determine when two requests came from the same user and should be counted as one unique access. This request id used to be a hash of the original IP address and the user agent. This approach however is vulnerable to a brute force attack to get the IP address back from the hash. Here’s what we are doing about that:

First, we anonymize the IP before generating the hash. So instead of using 171.23.11.209, we use 171.23.11.0.

Second, you need to deal with the existing request_ids. There is a new “DSGVO” section under “Tools” with a button that will rehash all existing request_ids with a randomly generated salt. That way it will become unfeasible to determine the original IP address but your analytics will stay the same.

In case you have a lot of downloads (let’s say much more than 50.000), you may want to do this via command line because that will be much quicker than via the tools section. You need wp-cli, then simply call wp eval 'podlove_rehash_tracking_request_ids();'. On a multisite, pass the blog id as a parameter: wp eval 'podlove_rehash_tracking_request_ids(42);'.

Other

  • fix Podlove Subscribe Button language parameter
  • fix rel="self" link in show feeds
  • fix Podlove Subscribe Button not delivering show feeds
  • templates: handle episode.show access when there is no show
  • templates: allow episode filtering by show, for example: {% for episode in podcast.episodes({show: "example"}) %}

Wie kann ich in Templates Shows filtern?
#2

When installing/updating from the WP plugin repository it immediately tells me podlove would still be at 2.7.4
and asks for an update available again. Verified on a fresh installation. Looks like the same old WP-repository-bugs…


#3

Same for me. And another strange problem occurred: After updating to 2.7.4 I get “Error loading audio files” in the Webplayer. In the console I found “Failed to load resource: the server responded with a status of 500 ()”. This error only appears in Safari and Chrome. In Firefox the player works. I cleared the cache, tried the repair button, but nothing changed.

Here is a link to my customers website: https://kuduhear.com/2018/05/03/011-scorpions/

Any suggestions?

UPDATE: With Safari on my iPhone the Webplayer works.


#4

Same here … and by removing the old and manually reinstalling the new Plug-In - right before I saw this post - , I crashed my whole Podcast configuration (no assets anymore, CSS missing, etc.) :frowning:

Restoring from backup …


#5

Same here


#6

I tried a rerelease, that did not help this time. Contacted WordPress support now, hoping they have a look at it.

If you want to manually update, it’s available here: https://downloads.wordpress.org/plugin/podlove-podcasting-plugin-for-wordpress.2.7.6.zip


#7

#läuft :wink:
Danke! <3


#8

Yay, it’s working :wink: Thx!!!