Sending episode cover art to Auphonic

Hi,

today I tried to adjust my workflow to control Auphonic from Podlove, not directly anymore. All worked fine, but

  • episode cover art was not transfered (I went for “Beitragsbild” in Podlove asset settings)
  • slug generation: (how) can I change the default slug from “mnemonic-number-title” to mnemonic<4digitnumberwithtrailingzeros>"?

For the first item: I created a new episode in publisher, entered title, number, subtitle, description, “Beitragsbild”, and then created a new Auphonic production from the Publisher by uploading my FLAC from my computer. All metadata was successfully added to the Auphonic production, just missing out on episode artwork. What else do I need to do, or is this a bug? Any ideas, @ericteubert?

Thanks!
Toby

I’ll look into both. Are you using the Gutenberg editor or classic (as that does affect some things)?

Classic! I’m too old for those changes :wink: thanks for looking into it, really appreciate it!

One additional information: switching the episode art (“Episodenbild”) to “Beitragsbild” led to all previous episodes having no episode art at all, since their “Beitragsbild” was not set. I switched back to Asset - PNG. Can I still switch to using Auphonic from Podlove and somehow send over the cover art?

Regarding the image: is should work with any episode image setting but requires a reload of the episode form between verifying the asset for the first time and creating the production.

I created an issue for it because the fix needs a little more work: https://github.com/podlove/podlove-publisher/issues/1178

Regarding the slug: The slug generation can’t be changed (at the moment). However I am changing one thing that I consider a bug: When importing from Auphonic, the slug from Auphonic is used but the field wasn’t marked as “set” so the slug was overridden by the autogeneration later. Now when importing the slug from Auphonic, I mark it as “set” and it should not be overridden after that.

What do you mean by “verifying the asset for the first time”? The “verify all assets” down below only works when Auphonic is done, so I guess it’s not that?

You’re right :man_facepalming: What I wanted to say is: you need to reload the page after setting the episode image. So if you set the post image, you need to save the episode (or reload) and only then the image will be transferred properly when creating a production. In any case, it’s a bug :slight_smile:

I tried just that with todays episode: set episode image, save, reload, save and reload again, then create Auphonic production: no transfer :frowning: I can try again in two weeks. Or, if you want to have a testing session with me, we can also meet :slight_smile:

Sure, send me a message a day before and we can look at it together :grin: :+1: