[solved] Episode 2 does not appear in the feed


I published my first episode with Podlove, created the feed, submitted it to iTunes and other podcatchers and everything went fine. Now I’ve released the second episode and for some reason it does not appear in the feed.

Also, I am not really clear regarding assets. Does every episode have it’s own asset or is there supposed to be one asset for all the mp3 files and one assets for all the jpg files?

Because when I go to feed settings, I have to chose one Episode media file, which is one of the assets I created. Or do I have to create a new feed for every episode, which has the same name as the other feed episodes but has a different episode media file it is pointing to?

Can you give us URLs if your blog and feeds so we can have a look?

Every episode you post needs one of the configured episode assets represented by a properly named file. So one configured “mp3” asset represents all the mp3 files for all the episodes you post. With two episodes there should be two mp3 files in total accordingly.

Each feed you create carries one of your episode assets to a podcasting client. If you have one mp3 asset you want to create one feed for this. The feeds reports all the episodes’ mp3 files to the client.

1 Like

I have a similar problem and still don’t quite understand the relationship between feeds and episode documents. It seems to me that a single feed should contain all episodes. That seems to be what Google Play wants, because when I setup two feeds for the same podcast (one for each episode) Google wouldn’t let me because the name of the Podcast was the same for both Episodes. So it told me I had a duplicate.

I have one Feed document. In it I have selected the first Episode. I have two Episode documents, each containing all of the Assets for the single episode (MP3, M4A and PNG). However, the RSS feed that is published only has the single episode. http://www.allergyfreemouse.com/feed/fa-fastpass-mp3/

Thanks for your assistance.

Looks like your episode 2 misses the associated assets. This should be visible in the episode page in the “Media Files” section. If there is no media file found, the episode does not show up in the feed (as the enclosure link would be pointing nowhere).

Regarding Google Play and feeds: this is Google’s ruling. They want just one feed per podcast and it looks as if they are actively preventing of posting multiple feeds with multiple formats. Nothing we can do about it. MP3 might be the best option for Google Play though.

Here is what my Episode 2 form looks like. So, I think it found the assets, but maybe I misunderstand what you mean by “misses the associated assets”

Thanks again

Also, the Asset “Food Allergy Fastpass #2” is the MP3 asset.

Hm, looks alright to me. Not sure what’s happening here. Any guesses, @ericteubert?

It looks like you are creating assets for each episode. Maybe the best is to remove all assets and create only one m4a asset, and one feed for this asset. Then make sure both episodes have a media file for this asset. Then both episodes should appear in the feed.

Only if this works, start adding more assets, like the episode cover (PNG image in your case).

Oh yes now I get what you have done here. Please note that the Assets are for all episodes. You need only one asset for each file that is published with every episode. One for the media file, one for a cover image. Two assets for the complete podcast and then never touch the asset configuration ever again.

That was it! Thanks guys.