[solved, kind of] Cover art disappears: Caching issue

Hi community

Last night I released a new episode. I did not change anything about my workflow. Unfortunately, the cover art does not get displayed. There is just a placeholder stating Poster Image.

The code behind it looks like this:

<img class="coverimg" src="http://GameTalk.FM/wp-content/cache/podlove/bf/49998296540a06b39d35a1a506372f/rueck%c2%adblick-2015-gt019_500x500.png" data-img="http://GameTalk.FM/wp-content/cache/podlove/bf/49998296540a06b39d35a1a506372f/rueck%c2%adblick-2015-gt019_500x500.png" alt="Poster Image">

After attempting a repair via Podlove -> Support -> Attempt Repair everything seemed to be fine again. The cover will be displayed. The code behind it will look like this:

<img class="coverimg" src="http://GameTalk.FM/wp-content/uploads/Logo-GameTalk-FM-1400x1400.png" data-img="http://GameTalk.FM/wp-content/uploads/Logo-GameTalk-FM-1400x1400.png" alt="Poster Image">

But: After a few minutes, this automatically changes back to the non-displaying state. It seems that as soon as the caching kicks in, the cover art can’t be dispalyed anymore.

It’s only this single episode that won’t display a cover art. It can be seen live here. It works just fine for all the others.

How can this be fixed?

Thanks in advance for your help!

Additionally, if this is of help:

Website http://GameTalk.FM
PHP Version 5.5.30
WordPress Version 4.4
Publisher Version 2.3.6
Web Player Version no web player found
Twig Version 1.23.1
open_basedir ok
curl Version 7.45.0
iconv available
simplexml ok
max_execution_time 50
upload_max_filesize 150M
memory_limit 256M
disable_classes
disable_functions exec, shell_exec, system, dl, passthru, proc_open, proc_close
permalinks ok (/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
assets
mp3 audio/mpeg
m4a audio/mp4

0 errors
0 notices
Nice, Everything looks fine!

I have investigated this a bit further:

It is the caching. In some way. I’ve checked the files where http://GameTalk.FM/wp-content/cache/podlove/bf/49998296540a06b39d35a1a506372f/rueck%c2%adblick-2015-gt019_500x500.png leads to. These images are fine when I download and check them on my PC. But they are not when I view them online on my webspace (placehodler gets displayed).

Deleting .../bf/49998296540a06b39d35a1a506372f/... manually did not help. Podlove will recreate the exact same folder and its content over and over again.

Update:
It might be the name of the image files. As soon as I change rueck%c2%adblick-2015-gt019_500x500.png to eg. rueckblick-2015-gt019_original.png it can be viewed online. But this does not solve my problem yet. The webplayer will not check for the new name. Podlove will recreate the files with the not working names. The files with the (working) filenames are ignored, obviously.

%C2%AD is a “soft hyphen”: -. Why is this even part of the name? The Episode Title is Rück­blick 2015 | GT019. Not a single soft hyphen in there.

So: How can I force Podlove to create a cached image with an other name than rueck%c2%adblick-2015-gt019_500x500.png? Or how can I change it manually?

1 Like

I’m not familiar with the escaping rules or stuff like that, but I would try to work-around this issue by renaming the image file drastically (e.g. cutting out the characters around this soft hypen: “rk…”). Just an initial idea. Hope this helps.

Thank you for your help.

The filename of the cached image depends on the title of your podcast episode. There is no soft hyphen in the episode title. So there shouldn’t be one in the filename (that then gets converted into %c2%ad) either. In other words: I don’t know where that %c2%ad comes from, but that’s an other question.

Nevertheless I tried your advice and renamed that cached image file and even changed that name accordingly in the cache.yml that is stored in the same folder.

Here is what happens:

  1. Podlove won’t find the file named rueck%c2%adblick-2015-gt019_500x500.png because I changed the name of the image with that name.
  2. Podlove will therefore load the non-cached original file. -> Everything looks good.
  3. A few minutes later, Podlove will start caching again.
  4. Podlove recreates a cached (not displayable) image named rueck%c2%adblick-2015-gt019_500x500.png.
  5. Podlove finds and “shows” that image. We are now back to where we were before.

To solve my problem, I need to either:

  1. Stop Podlove from caching this image.
    Or:
  2. Force Podlove to give that image a different, %c2%ad-free title when caching it.

But I don’t know how to.

I’m now in contact with my webhost to solve this problem from the other end: Make image files with an %c2%ad (and possibly other parameters) in their name displayable.

Update:
I tried to force Podlove to give the image a different name by renaming the episode from Rück­blick 2015 | GT019 to Jahresrück­blick 2015 | GT019.
Podlove did in fact create a new cached image with a different name matching the new title: jahresrueck%c2%adblick-2015-gt019_500x500.png. :sweat: Therefore: Same problem again. The %c2%ad is back, even if there is still no soft hyphen in the title of the episode.

Update 2:
I changed the titel now to Spielejahr 2015 | GT019. Podlove now won’t create a filename with %c2%ad in it (why should it in the first place?). Therefore the problem is kind of solved. It’s a work-around.

Update 3:
I changed the title back to the original one - just to see what happens. As expected, Podlove creates a new cached image file that matches the changed episode title. This time: rueckblick-2015-gt019_500x500.png. Just as it should have been in the first place. The problem is gone. At least for now. Strange. :sweat_smile:

1 Like

I also investigated some more and found that this problem is probably not related to the German Slugs plugin. After deactivating it, Podlove still inserts %c2%ad. However, I narrowed it down to the kb and the ü..k. Retyping both letters generates a correct slug. :confused:

@ericteubert: Looks like a very strange escaping bug in the slug generator.

1 Like

Thanks for examining the issue. I opened a card: https://trello.com/c/ZQR8gTE2/28-bug-escaping-problem-im-caching-slug

I discovered the same issue at my site. My solution (workaround) to prevent podlove from caching is to set the File Permissions of the Caching Folder to Non writeable (555).
After that everything is displaying the way it should on mit Site.
I know this an quick an dirty approach. So if you know a better option. Please let me know.

Sascha

Hi there,
I have the same problem with a new podcast (podcast.piqd.de) and it appeared from the very beginning. The episodes names do not include any letters that would produce a problem, like mentioned above, nore do the file names of my jpgs.
I have tried different approaches to make the webplayer display the pictures: first I uploaded them to my Wordpress Media files and simply chose them from there. But they disappeared again. Then I tried to import them with auphonic. But they disappeared again. I tried uploading them on several servers (the server for Erscheinungsraum, my other podcast; the server for the piqd Podcast (they are here and here) … what helps for a very short time seems to be to use the “Podlove” --> “Support” --> “Attempt Repair” button. but only after a few minutes with pictures they are gone again.
As Sascha did, I set the Permissions of the Caching Folder to 555 and now everything is displaying the way I want on the Site. But I would also be very thankful for any other option.

UPDATE: the Caching Folder Solutions also just worked for a few minutes o_O

Thanx

Katrin

@ericteubert opened a Trello card for this issue. I can’t open it tough. Any updates on that one?
It seems like this (rare) issue has not really been solved yet. I have not had it again since.

For people having this issue: 2.3.13 has fixed an image caching issue. So this might be solved now.

The image caching issue is back. (cc @ericteubert ) But this one is different. Might as well be user-stupidity. So I’m not sure yet if it’s a bug.

Tonight, the cover of my podcast disappeared again. Podlove again tries to fetch a cached image from a place where there is none.

Logo from Podlove Subscribe Button:
http://gametalk.fm/wp-content/cache/podlove/4c/52525cc3a772414f7476907e22992c/gametalk-%c2%b7-we-talk-games_400x400.png

Same for the cover displayed in the player:
http://gametalk.fm/wp-content/cache/podlove/4c/52525cc3a772414f7476907e22992c/gametalk-%c2%b7-we-talk-games_500x500.png

I’ve added a · symbol tho the name of my podcast. It’s now: GameTalk · We Talk Games!

I bet that little thing gets turned into %c2%b7 within the URL which leads to nowhere.

A caching rule like “do not transfer fancy symbols from podcast titles into the URL of the cached image” should fix this, shouldn’t it?

In the meantime I’ll switch to a less fancy symbol. Or a similar one. I guess the ones mentioned here should be working?

Fixed it the hardcore approach @ericteubert , see pull request: https://github.com/podlove/podlove-publisher/pull/895

1 Like