[solved] Slug in episode can not find asset

Hello community,
I’m setting up the podlove plugin. I’ve added 91 Episodes, one feed and one mp3 asset.
In each episode I typed in the number (field slug) to find the suitable asset.
But it does not combine the basic URL with the slug - so it can not find the mp3 file.

Does anybody know how to solve this problem?

Did you keep small and capital letters in mind?

Hi Joey,
only small letters: myfish-podcast- and the number as slug = myfish-podcast-1

I’m not sure if you understood correctly how this should be.

Your episode 1 should look something like:


Episode 2:


The Episode Media File Slug you have to enter in that field near the bottom of the episode is AwesomeEpisode1, EvenBetterEpisode2 and so on. Without the file extension. Not just a number at the end. Small and capital letters are to be respected.

Of course all your episodes should be stored at wherever your Upload Location in Podlove -> Podcast Settings -> Media is pointing at.

Hi Joey,
yes, I know.
But have a look at this. The slug is not working!

Here another example. The slug is equal for this system and the green mark isn’t correct.

If you’ve done it the way I’ve explained, it should be working. Maybe @ericteubert could assist you further.


have you tried those links ‘detect duration’, ‘update all media files’ and the asset file link (in your sample ‘‘myfish-podcast-.mp3’)’ - in my experience, a duration is only shown, when the files really can be found on your media file base (…/wp-content/podcast/ on your server) . And do you see those green check marks right to the file site (being cut off in your screen shot)?

if the file is indeed there, to what url does your brower resolve it to when you move your mouse over that link to the asset?

Hi Joey, I’m sry but I’ve done all points and it is still faulty.

Hi weHe,
thanks for your help. It is not working well.
Please have a look at all screenshots.

@myfish: there we go! try resetting the ‘Episode Asset URL Template’ on the WebSide-Tab
to its default setting - which is:


Thanks a lot weHe - it is doing well know!