Tracking makes URL not resolve properly

After updating, I can no longer leave tracking on because it breaks the URL resolution. It was working in the past, but now can’t find the file anymore. I host my files on S3 and when enabling tracking, it changes the URL a local address.

On the “Tracking” tab of “Expert Settings,” with tracking off, “Debug Tracking” shows:

https://s3.amazonaws.com/alexahost/mystery/149-Holiday5.mp3
https://s3.amazonaws.com/alexahost/mystery/149-Holiday5.mp3
:heavy_check_mark: Rewrite Rules Exist
:heavy_check_mark: URL resolves correctly
:heavy_check_mark: Consistent protocol chain
:heavy_check_mark: Geolocation database valid

But when turning tracking on, “Debug Tracking” shows:
https://s3.amazonaws.com/alexahost/mystery/149-Holiday5.mp3
https://mystery.alexaguy.me/podlove/file/490/s/debug/149-Holiday5.mp3

:heavy_check_mark: Rewrite Rules Exist
URL does not resolve correctly The cause might be a server specific SSL misconfiguration. To work around this, disable “Check for Assets with SSL-peer-verification” in Expert Settings or ask your admin/hoster for help.
:heavy_check_mark: Consistent protocol chain
:heavy_check_mark: Geolocation database valid

I’ve disabled “Check for Assets with SSL-peer-verification,” but that doesn’t fix it. Any ideas?

Thanks in advance,
Jeff