URL does not resolve correctly

after turning on “Tracking URL Parameters & Analytics” , i get the error “URL does not resolve correctly” for the generated public media URLs (in “Expert Settings” -> “Tracking” )

Support / system report:
`Website http://voreinemjahr.com
PHP Version 5.4.45-1~dotdeb+6.1
WordPress Version 4.4.2
Publisher Version 2.3.8
Web Player Version 2.0.19
Twig Version 1.23.1
open_basedir ok
curl Version 7.21.0
iconv available
simplexml ok
max_execution_time 30
upload_max_filesize 2M
memory_limit 256M
disable_functions pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,
permalinks ok (/index.php/%year%/%monthnum%/%day%/%postname%/)
podlove_permalinks ok
podcast_settings ok
web_player ok
podlove_cache on
mp3 audio/mpeg

0 errors
0 notices
Nice, Everything looks fine!`

apache’s error.log says: “File does not exist: /var/www/vej/podlove, referer: http://voreinemjahr.com/index.php/2016/02/09/vej002-kw6-2015-teil-22/

I tried to follow the suggestions made to the users having a similar problem, but with no success.

a 404 is returned when trying to access the generated URLs:
curl -IL http://voreinemjahr.com/podlove/file/54/s/debug/vej002-kw6-2015-teil-22.mp3 HTTP/1.1 404 Not Found Date: Tue, 09 Feb 2016 16:09:46 GMT Server: Apache Vary: Accept-Encoding Content-Type: text/html; charset=iso-8859-1

If i turn off the analytics, everything (still) works fine.

Any idea what i am doing wrong?

thanks in advance and best regards

It might be related to your URL structure which includes the index.php. That might either be a web server setup problem or a case that actually triggers a bug in the publisher.

Any opionions on this, @ericteubert?

to be honest - i don’t have a clue why or how the “index.php” thing got in there.
After your brilliant hint i went to the WP Permalinks Settings and chose the “day and name” option, went back to the podlove expert settings and activated “Tracking URL Parameters & Analytics”. Now everything seems to work like a charm. The URL resolves correctly now. I hope that tomorrow there will be some analytics data :slightly_smiling:
thank you very much Tim! :blush:

That’s what WordPress calls “almost pretty” permalinks: https://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks

This seems to happen when pretty permalinks are active but mod_rewrite is not available. It’s probably a bug on our end but I don’t feel like it’s worth investigating. Nobody wants this. It’s better fixed in the server config.