WebVTT file upload

Hi guys (and Eric),

I tried to upload a .vtt file to my episode but I have an error message that says:

Error parsing webvtt file: Unexpected end of file at line 92, pos 1984

Here is the .vtt file:
COMMENT_PENSENT.vtt.txt (2.0 KB)

(I put the .txt extension above because .vtt files are not accepted for download here)

=> Line 92 is the last line of my .vtt file and I didn’t check the “pos” number but I bet it is the last character of the file.

So I checked the file to see if there was anything wrong => I couldn’t find any.

Then I went to the MDN Web docs right here but couldn’t find anything here too that would explain this message.

So I have to rely on you to find the source of this problem :confused:.


1 Like

in the end, add a dot and make Enter twice in a normal text editor. then there should be no more error messages.

Thanks for you help Raumwelle, unfortunately it doesn’t fix my problem. May I ask you to test my file (see above) and tell me if it works for you?

And by the way Raumwelle, I just visited your site https://lautfunk.uber.space/monolog/ and when I click “Play”, the audio doesn’t start.

And when I open the Transcript tab to jump to a particular moment, it doesn’t work too.

Might be a temporary problem but now, you know.


oh habe ich jetzt gesehen und auch im sendegate nachgefragt was da sache ist.

danke für die info

oh I saw it now and also asked the sendegate what is going on.

thanks for the information

lass mir die vtt datei zu kommen und ich werde sie mir anschauen

let me get the vtt file and i will look at it

Sure @Raumwelle.

Let me know if you find something wrong.
I could also test a VTT file of yours and see if I still get an error message.


here is one of mine and it works.

lautfunk004.vtt.txt (15.6 KB)

Thanks Sascha. I made the test with your vtt file.

1. Transcript upload

I removed the “.txt” extension and renamed your file to make sure the slug was the same than for my audio file.

Next, I clicked on the “Import Transcript” button. It said “importing” for like 12 to 15 seconds before finally say “Accepts: WebVTT”.

Is it the message you have after downloading a transcript file?

Thereafter, when I went to the “Transcript” tab on the left, the transcript didn’t show up.


So It looks to me that the transcript was not recognized (still, I can assure you that the .vtt file has been properly added to the the Wordpress directory that contains the MP3 audio file).

Does the transcript file show up in the Transcript tab of your WordPress?

2. Transcript display

Also, how are you able to display the transcript tab at the bottom of the player?

I’ve checked “Transcripts Tab” in the settings but it doesn’t show up.


Thanks a lot for your help on this (right now, I’m really fed up with Podove…).


It also took me a certain amount of time until this worked with the vtt files and I think that this function is not yet important since the data cannot yet be read by google and so with no profit, when searching in google, it is just a nice pure gift for the listener.

So why not use the podlove for where it was made as a supplier of the feed that people listen to, the podcast on devices that are mobile and rarely from the computer or via the site.

I can understand that for a “classic” podcast, transcripts are just a “nice to have” option for the reasons you mentioned.

However and without going into boring details, they are essential for my very specific project.

Anyway, thanks again for your help and if you at least see what I did wrong to display the “Transcripts tab” at the bottom of the player), it would be really nice to record your screen using free tools like “Screen to Gif” (for Windows) which is the one I used to create the .gif files above or “Gifox” (for Mac).


I think there are problems with updating the interface when I switch elements on and off even when I click on memory, the old settings remain in the display of the player.

Before it was important that you click on save so that the player updates itself, but that’s just not the case with me.