Your episodes are hosted on a server which does not support byte-range requests


#1

My Wordpress website is hosted on Godaddy.
I have set up my pages, feed and so on.

Feed address: https://thebrandinggirl.com/feed/mp3/

Page:

https://thebrandinggirl.com/the-creative-faction-podcast/
Edit: http://feeds.feedburner.com/TheCreativeFactionPodcast created a feedburner, still same error.

I’m not sure where to start troubleshooting the issue so it’d be nice to get some help here :smiley: I’m new to this so any help is appreciated. Thank you!


#2

I guess you are referring to a error message given out by iTunes when submitting your podcast?

iTunes requires byte-range-request support from download servers (necessary to proceed downloads that have been cancelled by the user or network disconnects). If ypu host on GoDaddy’s servers, they need to fix that. This is not under control of the Podcast Publisher.


#3

Well, they say it’s the plugin.


#4

Well, let’s check that: what’s the URL of your episode downloads?


#5

Nevermind, you already posted everything that I need to know.

Checking for the file the server responds like this:

% curl -I https://thebrandinggirl.com/wp-content/uploads/podcast/01-falling-in-love-with-the-process.mp3           
HTTP/2 200 
date: Wed, 13 Dec 2017 23:38:24 GMT
content-type: audio/mpeg
set-cookie: __cfduid=d42b79447c5eb7a7d8544fdb44ddaaf211513208304; expires=Thu, 13-Dec-18 23:38:24 GMT; path=/; domain=.thebrandinggirl.com; HttpOnly
last-modified: Sun, 10 Dec 2017 08:33:39 GMT
etag: W/"5b4179f-19a8a5d-55ff8464f5ead-gzip"
vary: Accept-Encoding,User-Agent
strict-transport-security: max-age=0; includeSubDomains; preload
x-content-type-options: nosniff
server: cloudflare-nginx
cf-ray: 3cccc1bc3836412a-HAM

This list should include a line

Accept-Ranges: bytes

But it doesn’t. This is done by your web server. Podlove Publisher is not involved in returning the request. So you need to have your web server setup fixed.

For more information see: