"Failed to load resource: the server responded with a status of 404"

I see, thank you… isn’t the whole point in enabling the CDN Version that the local version isn’t used?

20190624-tt4ps

<iframe title="Podlove Web Player: Halbe Katoffl - Ep. 32: Ivana Jagla (SRB| KRO): Jugos, Basketballfamilie & Zusammenhalt | Sport-Edition" width="320" height="400" src="https://halbekatoffl.de/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html?episode=https%3A%2F%2Fhalbekatoffl.de%2F%3Fpodlove_player4%3D762" frameborder="0" scrolling="no" tabindex="0"></iframe>

Seems like the embed code still points to the local share version https://halbekatoffl.de/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html instead of the cdn one https://cdn.podlove.org/web-player/share.html

Confirmed. Meaning the CDN setting seams to be rendered falsely by Podlove Producer…

Maybe because I am using a template with {{ episode.player }}?

I manually replaced the share html portion link in the embed code but that doesn’t do the trick either. Any ideas why that doesn’t work. Thought that could be a quick fix for now…

Identified another issue, will investigate on that, seems like there is still a glitch in 4.5.7

Released a Publisher update with new Web Player yesterday, standing by for another release once the player is ready :slight_smile:

4.5.8 is released, seems to work: https://jsbin.com/rewepinire

In Chrome Version 75.0.3770.100 (Offizieller Build) (64-Bit) using
Mac OS 10.14 is still no output… in Safari (webkit) I see the player now again.

Chrome:
20190627-vhw51

regards

I guess the browser cache is still not fresh:

image

Yes. Thats right. A cache buster based on the version string would be great! I guess…

Thank you for your great work by the way. We work mostly on charitable products and this open source project is a marvel.

Much appreciated!

1 Like

Until Podlove Producer is updated I just hacked my way into it…

20190627-wfxvk

any news about bug fixing on Podlove Producer?

Thank you very much for making your “hack” available to us.

This issue in the code was of GREAT help

tks

Hi there,

we had the same problem. We fixed it by replacing a part of the original embed code, which was:
12

we replaced the marked part of that code by using https://www.urlencoder.org:
57

now it looks like that:
22

and finally works.

but we got even more trouble (no player at all showing when we embedded) with the latest update to of podlove podcast publisher (2.8.9), so we went back to 2.8.6. Now everything works fine for us.

Kadda

This issue should be fixed with Web Player version 4.5.9 (the invalid share base and the URL encoding). @ericteubert isn’t that the version that ships with 2.8.9

Must have missed the latest release. Publishing now.

1 Like

I am using version 2.9.0 and the error persists: even with the site configured to use PODLOVE CDN, the webplayer embed code does not change (it is using the player available in my installation):

image

code obtained from the share button:

<iframe title="Podlove Web Player: BITCAST - BitCast 036 – Libra – a "criptomoeda" do Facebook" width="320" height="400" src="https://bitcast.site/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html?episode=https%3A%2F%2Fbitcast.site%2F%3Fpodlove_player4%3D45" frameborder="0" scrolling="no" tabindex="0"></iframe>

To make matters worse, my installation’s player doesn’t work either (attached screen too):

image

again, @MaxZ hack is helping me a lot. thank you

The provided player configuration is missing the “origin” reference. That’s why the player tries to fetch all of the assets from the root url.

Is there anything I can do to get the player to get the correct source settings?

because, in my view, at first the correct way would be for the player to point to the PODLOVE CDN.

tks