"Failed to load resource: the server responded with a status of 404"


#1

I’m facing an unusual situation with the webplayer.

using the player on a third party site (embedded), the player works if the site editor is logged in (admin or editor)

however, if the same page is accessed in anonymous mode or by someone not logged in, the following error is reported in the console:

image

in my settings, I enabled the webplayer to be provided via CDN (https://cdn.podlove.org) as well as the option “oEmbed Support”

how can I fix this problem?

tks


#2

Hey,
@MaxZ already notified us yesterday about this issue: https://github.com/podlove/podlove-ui/issues/83
4.5.7 should fix this.


#3

By the way…

Have you considers visual regression testing to verify functionality before/after deployments?

There are also commercial vendors that offer free tiers to open source projects.

Best regards and thank you.

Max


#4

We have unit + integration tests for the core player and web-player. I just need time to add some for the share mode (still this is very hard to test because of the share setting). If you have development resources available I highly appreciate any sort of contribution :smiley:


#5

Great news. Yes, that was why I was thinking of the visual regression approach. I am trying to find a solution for the multifaceted technologies JS, PHP, CSS etc. producing an end result like a page or app. I want to deploy it for my projects but it’s on my todo for after summer. I let you know if I found a free and viable solution.

Regards!


#6

although it appears on the CDN that the code was changed to version 4.5.7 (https://cdn.podlove.org/web-player/embed.js), the player incorporation code still tries to use version 4.5.6 (see the inspection of the page in the photo below)
image

I do not know if this record matters, but I use the podlove publisher plugin to provide the podcast.

so the player request uses the following iframe:

<iframe title="Podlove Web Player: BITCAST - BitCast 035 – Aceitação, Meios de Pagamento e P2P" width="768" height="290" src="https://bitcast.site/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html?episode=https%3A%2F%2Fbitcast.site%2F%3Fpodlove_player4%3D44" frameborder="0" scrolling="no" tabindex="0"></iframe>

tks


#7

if you want to see, here is a page with the code entered that is not working correctly:

https://universocripto.net/outro-teste/

tks


#8

Our partner “Intergration durch Sport” has reenabled the old embeds and the problem prevails.
See https://integration.dosb.de/

Anything special we must do? We are using the CDN version but deleting cache also doesn’t change anything?


#9

The installation still points to the 4.5.6 version from the publisher: https://halbekatoffl.de/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html I already pinged @ericteubert to also provide a patch.


#10

I see, thank you… isn’t the whole point in enabling the CDN Version that the local version isn’t used?

20190624-tt4ps


#11
<iframe title="Podlove Web Player: Halbe Katoffl - Ep. 32: Ivana Jagla (SRB| KRO): Jugos, Basketballfamilie & Zusammenhalt | Sport-Edition" width="320" height="400" src="https://halbekatoffl.de/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html?episode=https%3A%2F%2Fhalbekatoffl.de%2F%3Fpodlove_player4%3D762" frameborder="0" scrolling="no" tabindex="0"></iframe>

Seems like the embed code still points to the local share version https://halbekatoffl.de/wp-content/plugins/podlove-podcasting-plugin-for-wordpress/lib/modules/podlove_web_player/player_v4/dist/share.html instead of the cdn one https://cdn.podlove.org/web-player/share.html


#12

Confirmed. Meaning the CDN setting seams to be rendered falsely by Podlove Producer…


#13

Maybe because I am using a template with {{ episode.player }}?


#14

I manually replaced the share html portion link in the embed code but that doesn’t do the trick either. Any ideas why that doesn’t work. Thought that could be a quick fix for now…


#15

Identified another issue, will investigate on that, seems like there is still a glitch in 4.5.7


[Bug] the embedding episodes player doesnt work after the last update
#16

Released a Publisher update with new Web Player yesterday, standing by for another release once the player is ready :slight_smile:


#17

4.5.8 is released, seems to work: https://jsbin.com/rewepinire


#18

In Chrome Version 75.0.3770.100 (Offizieller Build) (64-Bit) using
Mac OS 10.14 is still no output… in Safari (webkit) I see the player now again.

Chrome:
20190627-vhw51

regards


#19

I guess the browser cache is still not fresh:

image


#20

Yes. Thats right. A cache buster based on the version string would be great! I guess…

Thank you for your great work by the way. We work mostly on charitable products and this open source project is a marvel.

Much appreciated!